No more IE!請試著使用FirefoxGoogle Chrome等瀏覽器瀏覽
標頭的可愛Alaskan Malamute來自維基百科~

2010年5月3日 星期一

在 Ubuntu 10.04 64bit Edition 下安裝Flash Player 10


2010/11更新:
現在請看這邊的新文章,這篇舊的可以不需要了,但留做參考。


關於這個,我真的爬了好多文。

可是最後自己弄出了一個暴力解......


Adobe 瀆職很久了,64bit Flash Player for Linux 一直 alpha,打死不出。

理由是說他們在評估64位元 Player 的必要性 = =||


這件事情造成使用者很大的麻煩,還看過網友說
  勸你裝回32bit ,64bit 效能增進沒啥感覺,可是不相容馬上很有感覺

這真是可悲....



本來我有找到一個 Shell Script 可以幫忙自動安裝 Firefox 的 Flash Player ,原理是用 nspluginwrapper 讓64位元的 Ubuntu 使用32位元的 Flash Player ,不過在 10.04 沒用,不知道是因為 Ubuntu 本身的改變還是因為預載的Firefox是3.6.3


最後我用的辦法是,把
http://labs.adobe.com/downloads/flashplayer10_64bit.html
裡最下面的檔案下載下來




解壓縮後獲得 libflashplayer.so ,其實這就是 Flash Player 了。

2010/11/13更新:
ADOBE官方載點移到http://labs.adobe.com/downloads/flashplayer10.html這頁的這裡(可直接下載),大家可以順便更新喔

2010/7/28更新:
ADOBE官方已將載點關閉,為了讓大家依然可以使用,我擅自把它上傳了。
我想應該不只有我這麼做啦,不過如果想分享檔案的話可以不要直接貼連結嗎?
我不想找麻煩= =

下載點:MediaFire
&   MegaUpload



接下來的步驟我試了很久很久,而且試了很多次,不知道換過幾種方法,期間也不知道改變了幾次系統,所以能不能用還請多指教。


在無數次失敗之後,我把 nspluginwrapper 和其他 Flash Player 移除
使用:(終端機下輸入)

sudo apt-get remove nspluginwrapper flashplugin-nonfree
sudo apt-get remove nspluginwrapper




如果你有用 Ubuntu Tweak 之類的軟體裝過 Flash-installer 之類的 Flash ,也請移掉


如果怕移不乾淨,複製下面這幾行貼在終端機裡:

sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper




然後繼續講故事

愚笨的我,怒了。
於是發動無差別攻擊,把 libflashplayer.so 丟進所有可能有關的資料夾內。


我一共丟進了...
/usr/lib/adobe-flashplugin
/usr/lib/firefox-3.6.3
/usr/lib/firefox-3.6.3/plugins
/usr/lib/firefox/plugins
/usr/lib/mozilla/plugins
/lib64  (在64bit 系統裡等同於 /lib )

然後我就成功了!
所以你照著做應該也是可以成功的XD

因為這些都是系統資料夾,一般是使用者是沒有修改權限的。
如果你沒辦法把檔案複製進去,可以試著用下面這個指令:

sudo nautilus


你會得到一個有權限的視窗,在這裡是可以把檔案丟進去的,當然這也有能力刪掉裏面的任何檔案,請務必小心使用,但不用太緊張XD。


如果只針對 Firefox 的話,其實關鍵應該就是(感謝Timothy回覆):
/usr/lib/firefox/plugins


如果照著做失敗,請回報好嗎?謝謝囉~


總之,我終於擁有一個完整的Firefox了。

4 則留言:

威士頓 提到...

紅字的那句話真的是說的相當心有戚戚焉阿...XD

花巴特 提到...

XDD,威士頓你好~

我也是這麼覺得...但是為了4G的ram...(默)

不過我使用上沒啥大問題啦,感覺在Windows下64bit的不相容問題要嚴重的多,Linux社群更新(趕流行)的速度很快啊~(目前似乎就只有FlashPlayer...)

話說,你是第一個在這留言的「網友」唉!
(其實之前還有一個留言看不懂的外國人和一個查得到身份的樂團網友啦。威士頓你應該算是第一個在我的資訊相關文留言的網友,科科)

Timothy 提到...

put the libflashplayer.so here, /usr/lib/firefox/plugins, and thanks to ur link.d

花巴特 提到...

@Timothy:

我好奇的一點是,像是Midori、Epiphany之類的瀏覽器,他們也會去找Firefox底下的plugins嗎?

因為當時會用到那些瀏覽器,所以我那個亂雜的動作基本上是為了要做到「全系統」都能用Flashplayer啦。如果只是用Firefox的話以後會果決的丟進那個資料夾的~

可以解惑嗎?用其他瀏覽器的觀點來看。